Incident CPIC

Incident Report for Intermut

Resolved

The incident has been resolved.
Posted May 05, 2026 - 12:30 CEST

Update

We are continuing to investigate this issue.
Posted May 05, 2026 - 11:55 CEST

Investigating

Our teams are investigating an incident affecting CPIC (MentalHealthCare & PerinatalCare), teams are working to restore the situation as soon as possible.
Posted May 05, 2026 - 11:52 CEST